Back

Slow chat response due to issues with third-party provider

February 20, 2026 at 04:44 AM IST Resolved after 56m

Updates

Resolved

fixed

February 20, 2026 at 05:40 AM IST
Identified

Service disruption due to issues with third-party provider. We are actively investigating and working with our partners to restore normal operations.

February 20, 2026 at 04:44 AM IST