Back

Experiences severe slowness in the builder

February 3, 2026 at 02:47 PM IST Resolved after 2h 53m

Updates

Resolved

Issue was resolved

February 3, 2026 at 05:40 PM IST
Identified

We are currently fixing the issue

February 3, 2026 at 04:36 PM IST
Monitoring

We are currently monitoring the issue

February 3, 2026 at 04:12 PM IST
Investigating

We are currently investigating the issue

February 3, 2026 at 03:07 PM IST
Investigating

We are currently investigating the issue

February 3, 2026 at 02:48 PM IST
Investigating

We are currently investigating the issue

February 3, 2026 at 02:47 PM IST